Monday, August 10, 2009

MOHH Exploit can still do its job on latest Firmware 5.55

Did you heard that your anticipated games like Persona and G.I Joe on UMD requires 5.55 Firmware update? Worry no more, the latest save game exploit can still do its job on the said firmware.

Download: MOHH Exploit v2
Source: psp-hacks


Post a Comment